Web delivery issues for a small number of Apps in EU
Resolved
May 29, 2026 at 11:16am UTC
Post mortem
Universal Apps run shared host systems. These host systems have - of course - limited file storage. Initially we enforced hard file system quotas, but an underlying bug in BTRFS caused issues with that. So we lifted the hard limits and allowed exceeding the including file system limits. For Universal Apps, there is no automatic scaling, so that solution is actually better for clients too. We overbook storage, roughly by the factor of three, which would allow clients to use as twice as storage as the largest Uni plan. We regularly check for Apps that are exceeding the limits and write mails. Lately we have to do that more often.
Most commonly, excessive file storage usage is attributed to code/config misconfiguration. Most often find a lot of old local backups files (maybe some plugin?), but also a lot of cache files. Specifically the later is getting an issue more and more. Maybe because of bots more aggressivly crawling websites, that offer an unlimited number of possible pages.
We have health checks in place, alerting us on storage issues. In this case, the storage filled quickly, causing all kind of random errors. We pro-actively removed cache folders, which caused higher load on the host system, when Apps refilled the caches.
This architecture is of course not prefect. It's one of the many reasons we decided to create a new platform from scratch. The new platform solves this on multiple levels:
- Larger storage plans
- Optional "Autoscaling": either capped, or upgrade
After monitoring, we consider the issue now resolved.
Affected services
Updated
May 29, 2026 at 7:52am UTC
Apps should be back for now. But we are still investigating.
Affected services
Created
May 29, 2026 at 7:20am UTC
We are looking into web delivery issues for about 30 Apps hosted in the EU region of the old platform. The issues may have started around 06:00 UTC. Not all Apps are down, just some, they return random errors or timeouts.
Affected services