Back to overview
Degraded

TLS certificate issues

Jun 2, 2026 at 8:41am UTC
Affected services
US Pro Apps
US Universal Apps
EU Pro Apps
EU Universal Apps

Resolved
Jun 2, 2026 at 12:11pm UTC

We think to have resolved the certificate issue. It was related to a change in Let's Encrypt root chain certificate. This is something, that is not happening on a regular basis, so it was not included with general security monitoring of external sources. It affected only a small number of newly created or recently updated certificates. Contact us if you still see SSL issues.

Created
Jun 2, 2026 at 8:41am UTC

We are looking into issues for Let's Encrypt certificates that have been recently created or renewed.