Back to overview
Resolved

Issues with web delivery for some Apps in EU

Jul 27, 2026 at 7:05am UTC
Affected services
EU Universal Apps

Resolved
Jul 27, 2026 at 8:07pm UTC

The issue is not 100% resolved. We are still monitoring. As most Apps (except one) are online again, we close this incident for now.

Updated
Jul 27, 2026 at 10:10am UTC

We are still working on it, but ETA yet. Most Apps are online already. But we keep monitoring.

Updated
Jul 27, 2026 at 7:48am UTC

We are working on a fix, but unfortunately it's not so easy to contain it.

Created
Jul 27, 2026 at 7:05am UTC

Since ~08:00 we see issues with a number of Apps hosted in the EU region. It's about 70 Apps and as far as we can see, there is a DDoS attack going on. It's wide spread and thus hard to get in control.